Enum Constant Summary
Enum Constants
Hexadecimal encoded octets (e.g.
Spaced-separated hexadecimal encoded octets (e.g.
BASE-64 encoded characters.
Date and time with time zone (RFC 3339).
64-bit floating point number.
Duration (RFC 3339 Appendix A).
Email address (RFC 5321).
32-bit floating point number.
Internet host name (RFC 1123).
Internationalized email address (RFC 6531).
Internationalized host name (RFC 5890).
Internationalized Resource Identifier (RFC 3987).
IRI Reference (RFC 3987).
Used to hint UIs the input needs to be obscured.
Regular expression (ECMA-262).
Universal Resource Identifier (RFC 3986).
URI Reference (RFC 3986).
Universally Unique Identifier (RFC 4122).
Method Summary
All Methods Static Methods Instance Methods Concrete Methods
Create from lowercase dashed name.
boolean
Returns true if this format is in the provided list.
Returns the enum constant of this class with the specified name.
Returns an array containing the constants of this enum class, in
the order they are declared.
Enum Constant Details
FLOAT
32-bit floating point number.
DOUBLE
64-bit floating point number.
BYTE
BASE-64 encoded characters.
BINARY
Hexadecimal encoded octets (e.g. "00FF" ).
BINARY_SPACED
Spaced-separated hexadecimal encoded octets (e.g. "00 FF" ).
PASSWORD
Used to hint UIs the input needs to be obscured.
UON
UON notation (e.g. "(foo=bar,baz=@(qux,123))" ).
EMAIL
Email address (RFC 5321).
Since:
9.2.0
IDN_EMAIL
Internationalized email address (RFC 6531).
Since:
9.2.0
HOSTNAME
Internet host name (RFC 1123).
Since:
9.2.0
IDN_HOSTNAME
Internationalized host name (RFC 5890).
Since:
9.2.0
IPV4
IPv4 address (RFC 2673).
Since:
9.2.0
IPV6
IPv6 address (RFC 4291).
Since:
9.2.0
URI
Universal Resource Identifier (RFC 3986).
Since:
9.2.0
URI_REFERENCE
URI Reference (RFC 3986).
Since:
9.2.0
IRI
Internationalized Resource Identifier (RFC 3987).
Since:
9.2.0
IRI_REFERENCE
IRI Reference (RFC 3987).
Since:
9.2.0
UUID
Universally Unique Identifier (RFC 4122).
Since:
9.2.0
URI_TEMPLATE
URI Template (RFC 6570).
Since:
9.2.0
JSON_POINTER
JSON Pointer (RFC 6901).
Since:
9.2.0
RELATIVE_JSON_POINTER
Relative JSON Pointer.
Since:
9.2.0
REGEX
Regular expression (ECMA-262).
Since:
9.2.0
DURATION
Duration (RFC 3339 Appendix A).
Since:
9.2.0
TIME
Time (RFC 3339).
Since:
9.2.0
DATE_TIME_ZONE
Date and time with time zone (RFC 3339).
Since:
9.2.0
Method Details
values
Returns an array containing the constants of this enum class, in
the order they are declared.
Returns:
an array containing the constants of this enum class, in the order they are declared
valueOf
Returns the enum constant of this class with the specified name.
The string must match exactly an identifier used to declare an
enum constant in this class. (Extraneous whitespace characters are
not permitted.)
Parameters:
name - the name of the enum constant to be returned.
Returns:
the enum constant with the specified name
Throws:
IllegalArgumentException - if this enum class has no constant with the specified name
NullPointerException - if the argument is null
fromString
Create from lowercase dashed name.
Parameters:
value - The enum name. Must not be null .
Returns:
The enum.